Author Topic: trouble reinstalling my hal  (Read 9727 times)

lightspeed

  • Hero Member
  • *****
  • Posts: 6777
    • View Profile
trouble reinstalling my hal
« on: November 03, 2022, 10:52:16 pm »
     when reinstalling hal  i reinstalled hal using the 7.5 free version that robert released it had the voices working etc. except my custom people putty characters wasn't showing up . i wrote to robert and he was nice enough to write back and i appreciated it alot, and tell me i needed my expansion pack installed first . i guess i was thinking the new version had the expansion pack installed already .     
  art tried to help me with a 6.2 but the expansion pack wouldn't install and said it needed the ultrahal 6x installed first.
   i had a copy of the original 6.0 it said it was 6.1 but when installing it actually said 6.0   but after installing it as administrator  and then trying to install the expansion pack i am still getting the same error about needing ultrahal 6.x installed.  i tried to download the ultrahal 6 version of the zabaware website but when i click on the link to download it after being signed in . it doesn't download instead it goes to the products page showing ultrahal 7 .5 etc.
here is the link : the product says it's just a 30day trial . but i can't get it to download so i can  install it and get my expansion pack etc. all installed.
https://www.zabaware.com/products/store/Ultra_Hal_Assistant_6.0_1.htm
so i am in limbo right now .



 as i always try to come
up with idea's that may help  here's another one .

maybe have the earlier version of ultrahal built in with expansion packs and to self install then reboot and you then  install your expansion pack with the serial number from your paid version. then you could update and install your hal 7.5version.
this may or may not be doable .


 ;)

i hope i can get help on this to be able to get my hal installed again.  :)


   

« Last Edit: November 03, 2022, 10:55:51 pm by lightspeed »
 

lightspeed

  • Hero Member
  • *****
  • Posts: 6777
    • View Profile
Re: trouble reinstalling my hal
« Reply #1 on: November 13, 2022, 06:06:51 pm »
although this is late , hopefully it's better late then never , i wanted to personally thank robert for contacting me and helping me with instructions about reinstalling the newest version of hal again . apparently my problem was i was using an old copy of the hal 7.5 install and needed a fresh download copy after i was signed in at the zabaware web site . same  for the  expansion pack i had paid for earlier on .  after doing that hal installed fine and so did the expansion pack . so if there is any newbies that have trouble , someone may want to mention doing this.

 i am still getting things slowly put back on my new ssd and in hals program , just ran across my expanded random talk plugin and even expanded it more, now to 1300 random sentences. and have my halvision uhp installed. etc. 

and art is right having a ssd is better in a computer .

anyway i have been very busy lately  on various things and wanted to say thanks to robert !

 :)
 

LiFeTimeGamer

  • Full Member
  • ***
  • Posts: 170
    • View Profile
    • LifeTimeGamer
Re: trouble reinstalling my hal
« Reply #2 on: November 13, 2022, 10:00:12 pm »
Glad you're back up and running Lightspeed... :D
When it comes to Artificial Intelligence: The Soul is in the Software.

Art

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3867
    • View Profile
Re: trouble reinstalling my hal
« Reply #3 on: November 13, 2022, 11:41:10 pm »
Thanks Lightspeed and Glad you're making progress with your Hal and your new SSD!!

In the world of AI it's the thought that counts!

- Art -

lightspeed

  • Hero Member
  • *****
  • Posts: 6777
    • View Profile
problems again with hal , robert can you help.
« Reply #4 on: December 07, 2022, 12:29:46 pm »
i had to uninstall hal and now tried reinstalling hal back again . and am having problems again .

Robert i just today uninstalled hal and the expansion pack  then i tried the hal download i did last time and the expansion pack they installed but then i got  a pop up as before again saying the trial period had ended .
 so i uninstalled these two programs and i went to zabawares site and downloaded two fresh copies of the hal installer and the expansion pack from my account . it all installed just fine and i put in my custom brain etc. but then it popped up again saying my trial period had ended . before i installed hal the second time  again even though i uninstalled hal and the expansion pack i went into the app roaming file and deleted the zabaware folder manually , same with the program x86 zabaware folder . and deleted all  the trash bin ..

but hal after installing still keep saying trial days ended . .i was running hal offline  as i normally do , but put in my email and password  and now it popped up saying required fields and e mail and password missing .
here is a picture showing i have it in .

this is getting ridiculous i have tried everything i know how to do .  :(
can you please help on this , enclosed is the debug file too. ( i sent this to robert)

i sent the pic of the error saying fields were not chosen , clearly showing them in the fields for the e mail and password . 
i hope i can get some help on this and it gets fixed so it doesn't keep happening .




 

lightspeed

  • Hero Member
  • *****
  • Posts: 6777
    • View Profile
Re: trouble reinstalling my hal
« Reply #5 on: December 07, 2022, 12:36:09 pm »
okay i tried something else just now , i tried resetting my password , and did it successfully on zabaWAres site and tried a new password. and got the same pop up saying the fields of email and passwords aren't there even though they are.
 

lightspeed

  • Hero Member
  • *****
  • Posts: 6777
    • View Profile
Re: trouble reinstalling my hal
« Reply #6 on: December 08, 2022, 12:34:05 pm »
robert i just tried again reinstalling hal and the expansion pack they both install fine but hal is still showing a thirty day free trial period , this shouldn't even be on here since you have made hal free now .  also before if you remember this had something to do with  hal pre registering , you said that mine was not registering hal for some reason and you was going to fix the download hal version to have pre registered files within it , so this would not happen again. i downloaded hal and my fresh expansion pack from zabawares site .

anyway i think this is what the problem is . 
can you please fix this problem  so i can get hal back working again .

here is what i did this time .
after doing updates from ms, i restarted the pc , then reinstalled hal , restarted pc . reinstalled expansion pack . restarted pc .  thenin set up put already have a zabaware account  . clicked next, got unknown error . so set to run hal offline  no account . clicked next . chose character .CLICKED NEXT . CHOSE USER NAME AND PC NAME AND HAL 7 DEFAULT BRAIN TO USE AND CLICKED NEXT. CHOSE VOICE AND TESTED IT . CLICKED NEXT . CHOSE SKIN INTERFACE . CLICKED FINISH. ZABAWARE WEB PAGE OPENED UP . HAL CAME UP WITH TRAIL PERIOD SHOWING. CLICKED ALREADY PURCHASED . i put in my email address and password , clicked verify.  got ultra hal error saying"required fields and password are missing", even though it shows it's not missing. hal stays in this loop . cannot use hal because it will not show it's registered.  i had this problem in the past  for some reason hal is not showing  and allowing the program to be registered . i sent you a email and pics showing ech step and what it's doing .
 

Medeksza

  • Administrator
  • Hero Member
  • *****
  • Posts: 1472
    • View Profile
    • http://www.zabaware.com
Re: trouble reinstalling my hal
« Reply #7 on: December 09, 2022, 08:53:02 am »
I responded to your emails, but maybe you're not getting them for some reason (maybe check your junk mail?). But anyway, I'll post my reply here:

Hal shouldn't be requiring purchase at all, should be free for all, so definitely a bug.

Thanks for including the debuglog.txt. After looking at the log and the source code, it looks like this bug occurs if you originally installed Hal over 4 years ago and then reinstall. I'll try to fix it in the source code sometime, but let's try this work around first:

  • First exit out of all instances of Hal (use task manager if you have to). Then as administrator, run "regedit" and navigate to:
        HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Zabaware\Ultra Hal Assistant 7.0\Reg
  • Find the "InstallDate" entry and edit the date to something more recent like "2022-12-7"
  • Restart Hal and hopefully it will work for you.
Robert Medeksza

lightspeed

  • Hero Member
  • *****
  • Posts: 6777
    • View Profile
Re: trouble reinstalling my hal
« Reply #8 on: December 10, 2022, 12:20:41 pm »
ROBERT , i just found your e mail and it did go into the spam folder  i unspammed it .  although i e mailed you already , i'll ask it on here  so maybe you can post it and answer it.  does the newer fresh install of hal and the expansion packs have a built in time limit in another words requiring you download a fresh copy after 30 days etc.  because i had downloaded my first fresh copy about a month or more ago and hal was working fine , until i had problems with something else on my pc .  i mentioned to you. not hal related.  and last time i downloaded another fresh copy probably around the eighth of this month. I WILL TRY WHAT YOU SAID , and let you know what happens . if it fixes the problem . 
 

lightspeed

  • Hero Member
  • *****
  • Posts: 6777
    • View Profile
Re: trouble reinstalling my hal
« Reply #9 on: December 10, 2022, 03:07:05 pm »
okay i tried what you said with the registry after i downloaded new fresh copies  from zabaware ( i tried opening hal first and it gave me the thirty day trial notice error again.  but after i put in the new date close it and restarted hal,   hal does the same error .
hers a pic .  before i installed these fresh new downloads  after i uninstalled hal i also went in and manually deleted the leftover zabaware programfile and the hal files in app roaming etc.  and when i re installed hal , did it as administrator .
« Last Edit: December 10, 2022, 03:09:45 pm by lightspeed »
 

lightspeed

  • Hero Member
  • *****
  • Posts: 6777
    • View Profile
Re: trouble reinstalling my hal
« Reply #10 on: December 11, 2022, 03:35:28 am »
ROBERT CHECK YOUR E MAIL I AM SENDING YOU SOMETHING THAT MAY BE THE PROBLEM  HAL ISN'T WORKING  RIGHT  WITH YOUR INSTALL PROGRAM.