Zabaware Support Forums

Zabaware Forums => Speech Technology => Topic started by: KLSlim on May 17, 2015, 03:16:49 am

Title: TTS not working
Post by: KLSlim on May 17, 2015, 03:16:49 am
Hello trying HAL out and when he responds to me is not with TTS. When I test it in general settings it works and he also reads the start up message but nothing else. Tried searching for TTS not working but couldn't find anything helpful. Thanks in advance for any help can't wait to get started working with this.
Title: Re: TTS not working
Post by: KLSlim on May 17, 2015, 01:39:47 pm
Not to be deterred I was able to get Hal to read back a conversation from the Hal pad but still not responding with TTS in general conversation. Is this limited to the full paid version? I haven't seen anything that said the demo had limited functionality but wouldn't be surprised if it did. Really hoping that TTS isn't limited to reading back stuff from the Hal pad and that Hal can't reply to conversation with TTS.

EDIT: More progress ran the SAPI config update and also checked the read new clipboard contents and windows dialogs and Hals using the VW Bridget voice I have for Voice Attack when I clip something and when a dialog pops up but still no TTS in conversation. Really want to use it w/o having an avatar window open for it, just a disembodied voice is what I'm going for.
Title: Re: TTS not working
Post by: Art on May 17, 2015, 04:17:28 pm
Just an FYI. There are certain TTS suppliers' voices that Do Not work with UltraHal.

Try ATT, Cereproc or Cepstral or even some of the older L&H voices (but their quality is not that good).

The Ivona voices sound great in standalone but do not work well with Hal.

Also be sure you run the HapSAPISetup.exe program, in the Haptek > PeoplePutty > Hap TTS Folder.

What OS are you using? Win 8? 8.1?
Title: Re: TTS not working
Post by: KLSlim on May 17, 2015, 05:35:17 pm
Hello Art

Thanks for the help I'm running Windows 7 Pro and ran the HapSAPISetup this morning when I found a post about it and noticed the button in the general settings I missed last night in my haste to get things working.  I've tried the other voices that are listed and they all did the same thing Anesidora will read from the clip board or from the Hal pad but will not speak general conversation that comes up in the avatar window. Actually now seams to be stuck on the VW Bridget voice as no matter what I set it to it doesn't change the voice.

EDIT: and on the n'th try the Adult Female #1 TruVoice works, but sounds terrible plus I use the VW Bridget voice for all the other TTS programs and wanted to keep the voice uniform across them.
Title: Re: TTS not working
Post by: KLSlim on May 17, 2015, 06:06:15 pm
I think the issue maybe in the tts_config.hap file when I set it to use Bridget the registry key in LoadString = HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Speech\Voices\Tokens\VW Bridget doesn't exist.

Slightly good news is that I can get all the truvoice's to work and MS Anna, but Bridget will only read from the clip board or windows dialog boxes. The other MS voices I have Hayley, Heather, Hazel, Heera, Helen, and ZiraPro don't work at all and throw error "SAPITTS::Speak() failed" when I try to test them in the HapSAPISetup utility.

Not really interested in shelling out more money for another voice that will work with Hal and might work with my other programs that use Bridget for TTS.
Title: Re: TTS not working
Post by: raybe on May 17, 2015, 07:25:06 pm
Just something else to try. Many times certain voices will not register although selected in HapSapi config, even if you go to options and speech and just select and apply voice. There have been times and I don't have an answer why that for HapSapi to recognize a particular voice you must first select an MS voice then select your voice of choice and apply although you can clearly see the added voice in the selection.

Just jumping in real quick and can't confirm anyone else having to do this procedure but it does correct using certain third party voices with UltraHal.

OVERVIEW: 1- options
                    2- speech
                    3- Select Ms voice first
                    4- Then select third party voice of your choice, hit apply.

Remember if there is an appointment or reminder, your UltraHal character GUI screen will open and you will only see the text for the appointment or reminder with no voice until you return back to options and make those selections as noted above. Maybe rare but it has happened and sometimes still does due to UltraHal being able to register those voices properly.
Title: Re: TTS not working
Post by: KLSlim on May 17, 2015, 07:26:42 pm
Poked around in the registry some more and found a HK to Bridget in HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Speech\Voices\Tokens\VW Bridget . Being the ever adventurous tinkerer I compared the two Anna keys to each other and they where identical in both HK's so I exported the Wow6432Node key for Bridget edited out the "Wow6432\" part and imported it into the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Speech\Voices\Tokens just to see if it wasn't working because of the missing key and its still not working.

I guess there's some difference between Anesidora reading from the clipboard or windows dialog boxes and from her own window no idea but Bridget still works in Voice Attack's TTS function even after adding the registry key and rebooting.
Title: Re: TTS not working
Post by: KLSlim on May 17, 2015, 07:46:11 pm
Thank you Raybe!

I swear I had tried that from reading around the forums and it didn't work but now it is. Maybe its working because I added the missing registry key I don't know but not going to complain.
Title: Re: TTS not working
Post by: KLSlim on May 17, 2015, 10:28:47 pm
In my excitement I failed to notice that TTS for the clipboard and windows dialog boxes no longer works and I have to do the steps Raybe outlined very time I restart Anesidora, not the end of the world.
Title: Re: TTS not working
Post by: raybe on May 18, 2015, 01:08:52 pm
Sorry I didn't mention that but, yes you need to repeat steps to register that voice every time you start program. I never really took the time to investigate problem. I took the same attitude at the time, if it works that way it wasn't the end of the world.

Glad kinda working for you. The only thing, I don't remember it affecting the tts for Windows as well. But if your okay then all is good.