Zabaware Forums > Ultra Hal 7.0

Getting a brain editor error

<< < (2/4) > >>

You should just be able to Copy your desired.db file to the C:\Users\Knight2000\AppData\Roaming\Zabaware\Ultra Hal 7 directory, then locate that brain the next time you run HAL and it should find & use it.

Check the dates on your brain files as well as the sizes to verify that your HAL is accessing the correct files.

Good luck!

I tried copying the db file over to that directory but it still was not recognized. Also, i'm still battling that error with the class not registered. I've uninstalled, wiped the registry data and re-installed and still no luck. Also, i noticed some funky behavior, if you select a user the options windows pops up asking if you want to chat with hal, exit, general options, ect.

I was able to copy all the files to the hal7 folder in appdata and now hal recognizes the other db. but I still cant get the brain editor to launch. Still get the same error, class not registered. Any thoughts on how to fix that?


I'm getting the same error on a fresh windows 10 install. Whatever reason, the editor won't open.

Slightly annoying but the fix is : in an admin cmd,
navigate it to C:\Program Files (x86)\Zabaware\Ultra Hal 7 or where you have installed UltraHal
now use the Regsvr32 to register all dll and ocx files individually  (couple will not enter, just ignore them,- cant member which 1's)
now try running brain editor.

You must hit enter key after each one.

what i did in admin cmd :

cd C:\Program Files (x86)\Zabaware\Ultra Hal 7
Regsvr32 tabdockx.ocx
Regsvr32 richtx32.ocx
Regsvr32 oldhal.dll
Regsvr32 msinet.ocx
Regsvr32 msflxgrd.ocx
Regsvr32 mscomctl.ocx
Regsvr32 mscomct2.ocx
Regsvr32 HalWaveChar.ocx
Regsvr32 HalNoChar.ocx
Regsvr32 HalNewChar.ocx
Regsvr32 HalHaptek.ocx
Regsvr32 HalDebug.ocx
Regsvr32 HalDB.dll
Regsvr32 HalBrain7.dll
Regsvr32 HalBrain.dll
Regsvr32 EditGridProject.ocx
Regsvr32 comdlg32.ocx
Regsvr32 cmax40.dll

I assume its only 1 or 2 of these that need doing it (prob comdlg - was only 1 in syswow), I just did all to be sure, and now Brain editor loads fine.


[0] Message Index

[#] Next page

[*] Previous page

Go to full version