Zabaware Forums > Programming using the Ultra Hal Brain Editor

Getting an error opening brain editor

(1/3) > >>

Hi all,

I'm trying to open Hal's brain editor and I get an error. I attached the image of the error. Any idea's on how to solve this? I wanted to check here before i uninstall and re-install. Hoping there might be a fix other then that. I tired switching brains and launching the editor with no luck, same error.


Have you tried going to your Ultra Hal 7 folder and looking for the HalBrainEditor.exe file and double-clicking it?

It should bring up the Brain Editor and allow you to select from one of possibly several UHP brain files.

Check the version of your BrainEditor using the Windows File Explorer and right-click on it then select Details.

You should see a version number. Mine happens to be & the size is 1.09 MB.

My date modified is 10-5-2017 at 3:15 PM although yours could vary.

Otherwise, just make sure you have a recent copy of your .db and .uhp file(s), then you could do a reinstall and hopefully, that would fix the issue. If not, let us know.

Good luck!

Hey Art!

I have the same version as you and the size is the same, my modification date is 12-10-2017. I tried running the editor in compatibility mode but still no luck. I'm also noticing weirdness when speaking to Hal. short words like "hey" or "hi" do not produce a response and Hal seems to lag. I say that because after a few seconds each of the short words I spoke all show in his input section at once as if I spoke them one after the other. That could be the pc acting up, not sure. Maybe I should try re installing Hal? I'm running 7.5

Just to be on the safe side, you might consider doing a complete system scan with your Anti-Virus software and run MalwareBytes too.

If everything comes back clean, then reinstall Hal but keep a copy of your .db and .uhp brain file(s).

Best of luck!

Thanks Art! Ill keep you posted


[0] Message Index

[#] Next page

Go to full version