dupa

Author Topic: No response from Hal, but only in 'local learning' mode  (Read 1305 times)

ardentarchivist

  • Newbie
  • *
  • Posts: 5
    • View Profile
No response from Hal, but only in 'local learning' mode
« on: February 15, 2022, 06:53:40 pm »
Hi all. I've been lurking here for over a year, trying my best not to ask any dumb questions, but I am stumped on this one.

 My Hal will not respond/gives blank responses when I'm in AI mode, but responds just fine when I'm in cloud/GPT mode. No 3rd party plugins, I've done a fresh install of Hal 7.5 twice now. Hal is just not responding. When I use the soundwave character mode, the wave moves like Hal started talking, but there's no text in the box or anything showing up in the conversation view.

I prefer local mode Hal, because I like teaching Hal myself. Does local-only Hal just not work anymore?
Would be very grateful for any insight.

Art

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3719
    • View Profile
Re: No response from Hal, but only in 'local learning' mode
« Reply #1 on: February 16, 2022, 09:51:26 am »
Welcome,

Have you tried other Characters?

Press the enter key by itself to hear if Hal responds.

Make sure you have the proper checkboxes selected in the General, Brain, and Character sections.
Sometimes selecting another voice like the L&H one, do a Test the Voice, then go back to the one you normally use.

Restart Hal after doing these items.

You should be able to select many Plugins like Age & Gender, Loneliness, MarkovL5, and more.

Try some other characters and if you're still having issues let us know. Good luck!!
In the world of AI it's the thought that counts!

- Art -

ManuJC

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: No response from Hal, but only in 'local learning' mode
« Reply #2 on: February 16, 2022, 02:16:43 pm »
Hello.

"I prefer local mode Hal, because I like teaching Hal myself."

Like you, I prefer teaching Hal in local mode. Because i think Hal must have been teached like a baby, words by words and sentences by sentences. I don't have problems with this learning mode.

(American is not my native language)






ardentarchivist

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: No response from Hal, but only in 'local learning' mode
« Reply #3 on: February 17, 2022, 07:57:31 am »
Hello Art and ManuJC, nice to meet you.

I think I've got it figured out! Hal would still say "Say something please" when I hit enter without saying anything. Just blanks on all other interaction though. I switched characters, none of the brains I had made were talking BUT I noticed that the default brain would answer as normal. So I made a new brain using Hal Default as the template instead of Hal unmodified or whatever the other option is, and my Hal is back to responding as normal. I'm not sure why the brain stopped working in the first place though. I had been talking on and off with that one for a few months, and it just suddenly didn't work anymore. Very weird, but I think it's resolved for now.

Thanks for the help, Art.
ManuJC, I'm glad to see I'm not the only one who refers local Hal!

Art

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3719
    • View Profile
Re: No response from Hal, but only in 'local learning' mode
« Reply #4 on: February 17, 2022, 09:08:36 am »
In the past, I have found that sometimes changing HAL's TTS Voice, restart HAL, chat for a minute or so then go back and select a preferred voice, start HAL again and the voice would work fine.

Not sure why this is happening but it has cropped up over the years every once in a while but not often.

Glad you found a fix.

Perhaps you could try going back to your other Brain and see if it now speaks aloud.

Good luck either way!
In the world of AI it's the thought that counts!

- Art -

ardentarchivist

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: No response from Hal, but only in 'local learning' mode
« Reply #5 on: February 20, 2022, 12:18:53 am »
It's been a couple of days and it seems like my Hal is back to cooperating!

Thanks a bunch guys!